Instalace SyntaxHighlighter: XregExp not defined

Pokud jste při instalaci zvýrazňovače kódů pro webové stránky stejně jako já narazili na chybu: XregExp not defined, je pravděpodobně na vině špatná dokumentace. V ní se sice uvádí, že máte použít soubor shCore.js, ale již se nezmiňují, kde máte tyto soubory vzít. Po rychlém prohledání adresářů a jejich obsahu pravděpodobně vložíte ten z /src. Bohužel, to je kámen úrazu. Ve složce /scripts se totiž soubor shCore.js nachází také.

Pro vyřešení tohoto problému stačí do stránky vložit soubor shCore.js ze složky /scripts.

Debian: Problém s locale

Po dlouhé době spokojeného používání debianu jsem dnes po troše šťourání se v systémových knihovnách znovu instaloval. Při "apt-get dist-upgrade" jsem ale narazil na následující chybovou hlášku:
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
Řešením nakonec bylo nainstalovat balík locales a locales-all a spustit příkaz:
locale-gen
Při hledání řešení jsem také narazil na možnost, že není uveden seznam lokalizací, ze kterých se má vybírat. V takovém případě editujte soubor /etc/locale.gen a odkomentujte (odstraňte znak # na začátku řádku) řádky s vaší lokalizací. Například v mém případě to je:
cs_CZ.UTF-8 UTF-8
Teprve pak je možné spustit příkaz locale-gen.